 <!DOCTYPE html>
<!--[if (gte IE 9)|!(IE)]><!--><html lang="en-US"> <!--<![endif]-->
<head>

	<!-- Basic Page Needs
  ================================================== -->
	<meta http-equiv="X-UA-Compatible" content="IE=9" />
	<meta charset="UTF-8">
	<title>Glamping in Shanghai | Sinosplice</title>
<meta name="author" content="John Pasden">


	<!-- Mobile Specific Metas
  ================================================== -->
<meta name="viewport" content="width=device-width, initial-scale=1, maximum-scale=1">


	<!-- Modernizer
  ================================================== -->

	<!--[if lt IE 9]>
	<script src="https://www.sinosplice.com/wp-content/themes/florida-wp/js/modernizr.custom.11889.js" type="text/javascript"></script>
	<script src="https://www.sinosplice.com/wp-content/themes/florida-wp/js/respond.js" type="text/javascript"></script>
	<![endif]-->
		<!-- HTML5 Shiv events (end)-->
	<!-- MEGA MENU -->
 	
	
	<!-- Favicons
  ================================================== -->
<link rel="shortcut icon" href="https://www.sinosplice.com/wp-content/uploads/2016/05/sinosplice-icon_16x16-2.png">

	<!-- CSS + JS
  ================================================== -->

	<!-- This site is optimized with the Yoast SEO plugin v15.1 - https://yoast.com/wordpress/plugins/seo/ -->
	<meta name="robots" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1" />
	<link rel="canonical" href="https://www.sinosplice.com/life/archives/2020/10/16/glamping-in-shanghai" />
	<meta property="og:locale" content="en_US" />
	<meta property="og:type" content="article" />
	<meta property="og:title" content="Glamping in Shanghai | Sinosplice" />
	<meta property="og:description" content="I&#8217;ve been meaning to go &#8220;camping&#8221; in Shanghai for a while, knowing that whatever activity I engaged in would probably be pretty different from what I know as &#8220;camping&#8221; in the USA. Well, on the October holiday, I finally did it&#8230; my first glamping experience. (And yes, they even call it &#8220;glamping&#8221; here in Shanghai, too&#8230; 精致露营 in Chinese.) The campgrounds are located within a... Read More" />
	<meta property="og:url" content="https://www.sinosplice.com/life/archives/2020/10/16/glamping-in-shanghai" />
	<meta property="og:site_name" content="Sinosplice" />
	<meta property="article:publisher" content="https://www.facebook.com/Sinosplice/" />
	<meta property="article:published_time" content="2020-10-16T02:50:31+00:00" />
	<meta property="article:modified_time" content="2020-10-16T02:50:37+00:00" />
	<meta property="og:image" content="https://live.staticflickr.com/65535/50493140952_c8964b022c_b.jpg" />
	<meta name="twitter:card" content="summary_large_image" />
	<meta name="twitter:creator" content="@sinosplice" />
	<meta name="twitter:site" content="@sinosplice" />
	<script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"https://www.sinosplice.com/#website","url":"https://www.sinosplice.com/","name":"Sinosplice","description":"Try to Understand China. Learn Chinese.","potentialAction":[{"@type":"SearchAction","target":"https://www.sinosplice.com/?s={search_term_string}","query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://www.sinosplice.com/life/archives/2020/10/16/glamping-in-shanghai#primaryimage","inLanguage":"en-US","url":"https://live.staticflickr.com/65535/50493140952_c8964b022c_b.jpg"},{"@type":"WebPage","@id":"https://www.sinosplice.com/life/archives/2020/10/16/glamping-in-shanghai#webpage","url":"https://www.sinosplice.com/life/archives/2020/10/16/glamping-in-shanghai","name":"Glamping in Shanghai | Sinosplice","isPartOf":{"@id":"https://www.sinosplice.com/#website"},"primaryImageOfPage":{"@id":"https://www.sinosplice.com/life/archives/2020/10/16/glamping-in-shanghai#primaryimage"},"datePublished":"2020-10-16T02:50:31+00:00","dateModified":"2020-10-16T02:50:37+00:00","author":{"@id":"https://www.sinosplice.com/#/schema/person/53c76a7280c8f777478a82efd6ad19fc"},"inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://www.sinosplice.com/life/archives/2020/10/16/glamping-in-shanghai"]}]},{"@type":"Person","@id":"https://www.sinosplice.com/#/schema/person/53c76a7280c8f777478a82efd6ad19fc","name":"John Pasden","image":{"@type":"ImageObject","@id":"https://www.sinosplice.com/#personlogo","inLanguage":"en-US","url":"https://secure.gravatar.com/avatar/d859fc578d38acbdd93fcd1dfaef358a?s=96&d=mm&r=pg","caption":"John Pasden"},"description":"John is a Shanghai-based linguist and entrepreneur, founder of AllSet Learning.","sameAs":["http://www.sinosplice.com/"]}]}</script>
	<!-- / Yoast SEO plugin. -->


<link rel='dns-prefetch' href='//secure.gravatar.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel='dns-prefetch' href='//v0.wordpress.com' />
<link rel='dns-prefetch' href='//jetpack.wordpress.com' />
<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//s1.wp.com' />
<link rel='dns-prefetch' href='//s2.wp.com' />
<link rel='dns-prefetch' href='//public-api.wordpress.com' />
<link rel='dns-prefetch' href='//0.gravatar.com' />
<link rel='dns-prefetch' href='//1.gravatar.com' />
<link rel='dns-prefetch' href='//2.gravatar.com' />
<link rel="alternate" type="application/rss+xml" title="Sinosplice &raquo; Feed" href="https://www.sinosplice.com/feed" />
<link rel="alternate" type="application/rss+xml" title="Sinosplice &raquo; Comments Feed" href="https://www.sinosplice.com/comments/feed" />
<link rel="alternate" type="application/rss+xml" title="Sinosplice &raquo; Glamping in Shanghai Comments Feed" href="https://www.sinosplice.com/life/archives/2020/10/16/glamping-in-shanghai/feed" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.0\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.0\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.sinosplice.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=7f2676ed5edc5ccbeabab231e04548d1"}};
			!function(e,a,t){var r,n,o,i,p=a.createElement("canvas"),s=p.getContext&&p.getContext("2d");function c(e,t){var a=String.fromCharCode;s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,e),0,0);var r=p.toDataURL();return s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,t),0,0),r===p.toDataURL()}function l(e){if(!s||!s.fillText)return!1;switch(s.textBaseline="top",s.font="600 32px Arial",e){case"flag":return!c([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])&&(!c([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!c([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]));case"emoji":return!c([55357,56424,8205,55356,57212],[55357,56424,8203,55356,57212])}return!1}function d(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(i=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},o=0;o<i.length;o++)t.supports[i[o]]=l(i[o]),t.supports.everything=t.supports.everything&&t.supports[i[o]],"flag"!==i[o]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[i[o]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(r=t.source||{}).concatemoji?d(r.concatemoji):r.wpemoji&&r.twemoji&&(d(r.twemoji),d(r.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='mb.miniAudioPlayer.css-css'  href='https://www.sinosplice.com/wp-content/plugins/wp-miniaudioplayer/css/miniplayer.css?ver=1.9.3' type='text/css' media='screen' />
<link rel='stylesheet' id='wp-block-library-css'  href='https://www.sinosplice.com/wp-includes/css/dist/block-library/style.min.css?ver=7f2676ed5edc5ccbeabab231e04548d1' type='text/css' media='all' />
<style id='wp-block-library-inline-css' type='text/css'>
.has-text-align-justify{text-align:justify;}
</style>
<link rel='stylesheet' id='main-style-css'  href='https://www.sinosplice.com/wp-content/themes/florida-wp/css/master-min.php?ver=7f2676ed5edc5ccbeabab231e04548d1' type='text/css' media='all' />
<link rel='stylesheet' id='google_fonts_css-css'  href='https://fonts.googleapis.com/css?family=Raleway%3A300%2C400%2C600%2C700&#038;ver=7f2676ed5edc5ccbeabab231e04548d1' type='text/css' media='all' />
<link rel='stylesheet' id='gfont-style-css'  href='https://fonts.googleapis.com/css?family=Roboto%3A100%2C300%2C400%2C500%2C700%7CRoboto+Slab%3A300%2C400%2C700&#038;ver=7f2676ed5edc5ccbeabab231e04548d1' type='text/css' media='all' />
<link rel='stylesheet' id='webnus-dynamic-styles-css'  href='https://www.sinosplice.com/wp-content/themes/florida-wp/css/dyncss.css?ver=7f2676ed5edc5ccbeabab231e04548d1' type='text/css' media='all' />
<style id='webnus-dynamic-styles-inline-css' type='text/css'>
#wrap ul#nav * { font-size:20px; }#wrap ul#nav * { letter-spacing:2px; }#wrap ul#nav * { line-height:20px; }#wrap p { font-size:20px; }#wrap p { line-height:28px; }a {color:#1e73be;}a:hover {color:#23a5dd;}a:visited {color:#578fbf;}#wrap #scroll-top a {background-color:#cecece;}#wrap #scroll-top a:hover {background-color:#81d742;}#wrap .blog-post h4, .blog-post h1, #wrap .blog-post h3, #wrap .blog-line h4, #wrap .blog-single-post h1 { font-family:Raleway;}#footer { background-color:#dddddd; }.footbot { background-color:#f2f2f2; }#headline, #headline2 {padding: 0}#main-content a:link {text-decoration:none;}#main-content a:visited {text-decoration:none;}#main-content a:hover {text-decoration:underline;}#main-content a:active {text-decoration:underline;}#main-content a img {text-decoration:none;}section.wpb_row{margin-bottom:0}#main-content ul, #main-content ol {padding-left:2.5em;list-style-position: outside;}#main-content ul li, #main-content ol li {margin: 0 0 0.5em 1em;line-height:1.5em;font-size: 150%;}.post ul li, .post ol li {margin: 0 0 0.3em 0;line-height:1.5em;font-size: 150%;}#main-content .wpb_text_column {padding-right: 2em;padding-bottom: 1em;}div.alignleft {float: left;margin: 0 2em 1em 0;}div.alignright {float: right;margin: 0 0 1em 2em;}
</style>
<link rel='stylesheet' id='parent-style-css'  href='https://www.sinosplice.com/wp-content/themes/florida-wp/style.css?ver=7f2676ed5edc5ccbeabab231e04548d1' type='text/css' media='all' />
<link rel='stylesheet' id='child-style-css'  href='https://www.sinosplice.com/wp-content/themes/Florida_child_theme/style.css?ver=7f2676ed5edc5ccbeabab231e04548d1' type='text/css' media='all' />
<link rel='stylesheet' id='social-logos-css'  href='https://www.sinosplice.com/wp-content/plugins/jetpack/_inc/social-logos/social-logos.min.css?ver=9.0.2' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css'  href='https://www.sinosplice.com/wp-content/plugins/jetpack/css/jetpack.css?ver=9.0.2' type='text/css' media='all' />
<script type='text/javascript' src='https://www.sinosplice.com/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp' id='jquery-core-js'></script>
<script type='text/javascript' src='https://www.sinosplice.com/wp-content/plugins/wp-miniaudioplayer/js/jquery.mb.miniAudioPlayer.min.js?ver=1.9.3' id='mb.miniAudioPlayer-js'></script>
<script type='text/javascript' src='https://www.sinosplice.com/wp-content/plugins/wp-miniaudioplayer/js/map_overwrite_default_me.js?ver=1.9.3' id='map_overwrite_default_me-js'></script>
<script type='text/javascript' src='https://www.sinosplice.com/wp-content/plugins/google-analyticator/external-tracking.min.js?ver=6.5.4' id='ga-external-tracking-js'></script>
<link rel="https://api.w.org/" href="https://www.sinosplice.com/wp-json/" /><link rel="alternate" type="application/json" href="https://www.sinosplice.com/wp-json/wp/v2/posts/9307" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.sinosplice.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.sinosplice.com/wp-includes/wlwmanifest.xml" /> 

<link rel='shortlink' href='https://wp.me/p9KRgB-2q7' />
<link rel="alternate" type="application/json+oembed" href="https://www.sinosplice.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.sinosplice.com%2Flife%2Farchives%2F2020%2F10%2F16%2Fglamping-in-shanghai" />
<link rel="alternate" type="text/xml+oembed" href="https://www.sinosplice.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.sinosplice.com%2Flife%2Farchives%2F2020%2F10%2F16%2Fglamping-in-shanghai&#038;format=xml" />
   <link rel="stylesheet" type="text/css" href="https://www.sinosplice.com/wp-content/plugins/sinosplice-tooltips/style/SinospliceTooltips.css" />
   <link rel="stylesheet" type="text/css" href="https://www.sinosplice.com/wp-content/plugins/sinosplice-tooltips/themes/yellow.css" />
   <script type="text/javascript" src="https://www.sinosplice.com/wp-content/plugins/sinosplice-tooltips/js/addtones.js"></script>
   <script type="text/javascript" src="https://www.sinosplice.com/wp-content/plugins/sinosplice-tooltips/js/SinospliceTooltips.js"></script>
   <script type="text/javascript">
      var spanclass = 'info';
      var originaltext = 'yes';
      var toneconversion = 'yes1';
      eST = function(){enableSinospliceTooltips()};
      if (window.addEventListener) // W3C standard
         window.addEventListener('load',eST,false)
      else if (window.attachEvent) // MSIE
         window.attachEvent('onload',eST);
   </script>
<!-- start miniAudioPlayer custom CSS -->

<style id="map_custom_css">
       /* DO NOT REMOVE OR MODIFY */
/*{'skinName': 'mySkin', 'borderRadius': 5, 'main': 'rgb(255, 217, 102)', 'secondary': 'rgb(68, 68, 68)', 'playerPadding': 0}*/
/* END - DO NOT REMOVE OR MODIFY */
/*++++++++++++++++++++++++++++++++++++++++++++++++++
Copyright (c) 2001-2014. Matteo Bicocchi (Pupunzi);
http://pupunzi.com/mb.components/mb.miniAudioPlayer/demo/skinMaker.html

Skin name: mySkin
borderRadius: 5
background: rgb(255, 217, 102)
icons: rgb(68, 68, 68)
border: rgb(55, 55, 55)
borderLeft: rgb(255, 230, 153)
borderRight: rgb(255, 204, 51)
mute: rgba(68, 68, 68, 0.4)
download: rgba(255, 217, 102, 0.4)
downloadHover: rgb(255, 217, 102)
++++++++++++++++++++++++++++++++++++++++++++++++++*/

/* Older browser (IE8) - not supporting rgba() */
.mbMiniPlayer.mySkin .playerTable span{background-color:#ffd966}
.mbMiniPlayer.mySkin .playerTable span.map_play{border-left:1px solid #ffd966;}
.mbMiniPlayer.mySkin .playerTable span.map_volume{border-right:1px solid #ffd966;}
.mbMiniPlayer.mySkin .playerTable span.map_volume.mute{color: #444444;}
.mbMiniPlayer.mySkin .map_download{color: #444444;}
.mbMiniPlayer.mySkin .map_download:hover{color: #444444;}
.mbMiniPlayer.mySkin .playerTable span{color: #444444;}
.mbMiniPlayer.mySkin .playerTable {border: 1px solid #444444 !important;}

/*++++++++++++++++++++++++++++++++++++++++++++++++*/

.mbMiniPlayer.mySkin .playerTable{background-color:transparent; border-radius:5px !important;}
.mbMiniPlayer.mySkin .playerTable span{background-color:rgb(255, 217, 102); padding:3px !important; font-size: 20px;}
.mbMiniPlayer.mySkin .playerTable span.map_time{ font-size: 12px !important; width: 50px !important}
.mbMiniPlayer.mySkin .playerTable span.map_title{ padding:4px !important}
.mbMiniPlayer.mySkin .playerTable span.map_play{border-left:1px solid rgb(255, 204, 51); border-radius:0 4px 4px 0 !important;}
.mbMiniPlayer.mySkin .playerTable span.map_volume{padding-left:6px !important}
.mbMiniPlayer.mySkin .playerTable span.map_volume{border-right:1px solid rgb(255, 230, 153); border-radius:4px 0 0 4px !important;}
.mbMiniPlayer.mySkin .playerTable span.map_volume.mute{color: rgba(68, 68, 68, 0.4);}
.mbMiniPlayer.mySkin .map_download{color: rgba(255, 217, 102, 0.4);}
.mbMiniPlayer.mySkin .map_download:hover{color: rgb(255, 217, 102);}
.mbMiniPlayer.mySkin .playerTable span{color: rgb(68, 68, 68);text-shadow: none!important;}
.mbMiniPlayer.mySkin .playerTable span{color: rgb(68, 68, 68);}
.mbMiniPlayer.mySkin .playerTable {border: 1px solid rgb(55, 55, 55) !important;}
.mbMiniPlayer.mySkin .playerTable span.map_title{color: #000; text-shadow:none!important}
.mbMiniPlayer.mySkin .playerTable .jp-load-bar{background-color:rgba(255, 217, 102, 0.3);}
.mbMiniPlayer.mySkin .playerTable .jp-play-bar{background-color:#ffd966;}
.mbMiniPlayer.mySkin .playerTable span.map_volumeLevel a{background-color:rgb(94, 94, 94); height:80%!important }
.mbMiniPlayer.mySkin .playerTable span.map_volumeLevel a.sel{background-color:#444444;}
.mbMiniPlayer.mySkin  span.map_download{font-size:50px !important;}
/* Wordpress playlist select */
.map_pl_container .pl_item.sel{background-color:#ffd966 !important; color: #444444}
/*++++++++++++++++++++++++++++++++++++++++++++++++*/figure.wp-block-audio{opacity: 0;}
       </style>
	
<!-- end miniAudioPlayer custom CSS -->	
<style type='text/css'>img#wpstats{display:none}</style><style type="text/css" media="screen">body{  } </style><script type="text/javascript">
	var _gaq = _gaq || [];
  
	_gaq.push(['_setAccount', 'UA-340127-1']);
    _gaq.push(['_addDevId', 'i9k95']); // Google Analyticator App ID with Google
	_gaq.push(['_trackPageview']);

	(function() {
		var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
		                ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
		                var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
	})();
</script><meta property="og:title" content="Glamping in Shanghai" />
<meta property="og:type" content="article" />
<meta property="og:image" content="" />
<meta property="og:url" content="https://www.sinosplice.com/life/archives/2020/10/16/glamping-in-shanghai" />
<meta property="og:description" content="I&#8217;ve been meaning to go &#8220;camping&#8221; in Shanghai for a while, knowing that whatever activity I engaged in would probably be pretty different from what I know as &#8220;camping&#8221; in the USA. Well, on the October holiday, I finally did it&#8230; my first glamping experience. (And yes, they even call it &#8220;glamping&#8221; here in Shanghai, too&#8230; 精致露营 in Chinese.) The campgrounds are located within a... Read More" />
<meta property="og:site_name" content="Sinosplice" />
<meta name="generator" content="Powered by WPBakery Page Builder - drag and drop page builder for WordPress."/>
			<style type="text/css">
				/* If html does not have either class, do not show lazy loaded images. */
				html:not( .jetpack-lazy-images-js-enabled ):not( .js ) .jetpack-lazy-image {
					display: none;
				}
			</style>
			<script>
				document.documentElement.classList.add(
					'jetpack-lazy-images-js-enabled'
				);
			</script>
		<!-- Google Analytics Tracking by Google Analyticator 6.5.4: http://www.videousermanuals.com/google-analyticator/ -->
<script type="text/javascript">
    var analyticsFileTypes = [''];
    var analyticsSnippet = 'disabled';
    var analyticsEventTracking = 'enabled';
</script>
<script type="text/javascript">
	(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
	(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
	m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
	})(window,document,'script','//www.google-analytics.com/analytics.js','ga');
	ga('create', 'UA-340127-1', 'auto');
 
	ga('send', 'pageview');
</script>
			<style type="text/css" id="wp-custom-css">
				/*
Welcome to Custom CSS!

To learn how this works, see http://wp.me/PEmnE-Bt
*/
@media (min-width: 960px) {
	.logo img {
		margin-top: 15px !important;
	}
}

@media (min-width: 1200px) {
	.logo img {
		margin-top: 12px !important;
	}
}

@media (max-width: 960px) {
	.logo img {
		margin-top: 3px !important;
	}
}

@media (max-width: 768px) {
	.logo img {
		margin-top: 3px !important;
	}
}

@media (max-width: 480px) {
	.logo img {
		margin-top: 3px !important;
	}
}

#nav > li.current::after,
#header.sm-rgt-mn #menu-icon span.mn-ext1,
#header.sm-rgt-mn #menu-icon span.mn-ext2,
#header.sm-rgt-mn #menu-icon span.mn-ext3 {
	background-color: #2d7200;
}

/*
	CSS Migrated from Jetpack:
*/

/*
Welcome to Custom CSS!

To learn how this works, see http://wp.me/PEmnE-Bt
*/
@media (min-width: 960px) {
	.logo img {
		margin-top: 15px !important;
	}
}

@media (min-width: 1200px) {
	.logo img {
		margin-top: 12px !important;
	}
}

@media (max-width: 960px) {
	.logo img {
		margin-top: 3px !important;
	}
}

@media (max-width: 768px) {
	.logo img {
		margin-top: 3px !important;
	}
}

@media (max-width: 480px) {
	.logo img {
		margin-top: 3px !important;
	}
}

#nav > li.current::after,
#header.sm-rgt-mn #menu-icon span.mn-ext1,
#header.sm-rgt-mn #menu-icon span.mn-ext2,
#header.sm-rgt-mn #menu-icon span.mn-ext3 {
	background-color: #2d7200;
}

/* Indiviual Post Page Edits */

.wp-block-image figcaption {
    margin-top: 0;
    margin-bottom: 1.8em;
}			</style>
		<noscript><style> .wpb_animate_when_almost_visible { opacity: 1; }</style></noscript></head>







<body class="post-template-default single single-post postid-9307 single-format-standard default-header  wpb-js-composer js-comp-ver-6.4.0 vc_responsive">

	<!-- Primary Page Layout
	================================================== -->

<div id="wrap" class="colorskin- ">



<header id="header" class="horizontal-w  sm-rgt-mn  ">
<div class="container">
<div class="col-md-3 col-sm-3 logo-wrap">
<div class="logo">
<a href="https://www.sinosplice.com/"><img src="https://www.sinosplice.com/wp-content/uploads/2016/11/sinosplice-logo_480x176-300x110.png" width="240" id="img-logo-w1" alt="logo" class="img-logo-w1"></a><a href="https://www.sinosplice.com/"><img src="https://www.sinosplice.com/wp-content/uploads/2016/11/sinosplice-logo_480x176-300x110.png" width="240" id="img-logo-w2" alt="logo" class="img-logo-w2"></a><span class="logo-sticky"><a href="https://www.sinosplice.com/"><img src="https://www.sinosplice.com/wp-content/uploads/2016/11/sinosplice-logo_480x176-300x110.png" width="120" id="img-logo-w3" alt="logo" class="img-logo-w3"></a></span></div></div>
<nav id="nav-wrap" class="nav-wrap1 col-md-9 col-sm-9">
	<div class="container">
		


		<div id="search-form">
		<a href="javascript:void(0)" class="search-form-icon"><i id="searchbox-icon" class="fa-search"></i></a>
	<div id="search-form-box" class="search-form-box">
			<form action="https://www.sinosplice.com/" method="get">
				<input type="text" class="search-text-box" id="search-box" name="s">
			</form>
			</div>
		</div>
						<ul id="nav"><li id="menu-item-7482" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-7482"><a title="Sinosplice Home" href="https://www.sinosplice.com/" data-description="">Home</a></li>
<li id="menu-item-7484" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-7484"><a title="About John Pasden" href="https://www.sinosplice.com/about" data-description="">About</a></li>
<li id="menu-item-7485" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-7485"><a title="Free Resources for Learning Mandarin Chinese" href="https://www.sinosplice.com/learn-chinese" data-description="">Learn Chinese</a></li>
<li id="menu-item-7483" class="menu-item menu-item-type-post_type menu-item-object-page current_page_parent menu-item-7483"><a href="https://www.sinosplice.com/life" data-description="">Blog</a></li>
</ul>	</div>
</nav>
		<!-- /nav-wrap -->
</div>

</header>

<!-- end-header -->


 <section class="container page-content" >
    <hr class="vertical-space2">
    	<section class="col-md-9 cntt-w">
		      <article class="blog-single-post">
	  
				<div class="post-trait-w"> 		 <h1>Glamping in Shanghai</h1> 
		</div>
	    <div class="post post-9307 type-post status-publish format-standard hentry category-personal tag-camping tag-entertainment tag-observations tag-shanghai">
          
           <div class="postmetadata">

			
		<div class="au-avatar"><img alt src="https://secure.gravatar.com/avatar/d859fc578d38acbdd93fcd1dfaef358a?s=90&#038;d=mm&#038;r=pg" class="avatar avatar-90 photo jetpack-lazy-image" height="90" width="90" loading="lazy" data-lazy-srcset="https://secure.gravatar.com/avatar/d859fc578d38acbdd93fcd1dfaef358a?s=180&#038;d=mm&#038;r=pg 2x" data-lazy-src="https://secure.gravatar.com/avatar/d859fc578d38acbdd93fcd1dfaef358a?s=90&amp;is-pending-load=1#038;d=mm&#038;r=pg" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img alt='' src='https://secure.gravatar.com/avatar/d859fc578d38acbdd93fcd1dfaef358a?s=90&#038;d=mm&#038;r=pg' srcset='https://secure.gravatar.com/avatar/d859fc578d38acbdd93fcd1dfaef358a?s=180&#038;d=mm&#038;r=pg 2x' class='avatar avatar-90 photo' height='90' width='90' loading='lazy'/></noscript></div>
					
		<h6 class="blog-author"><strong>by</strong> John Pasden </h6>
						<h6 class="blog-cat"><strong>in</strong> <a href="https://www.sinosplice.com/life/archives/category/personal" rel="category tag">personal</a> </h6>
						<h6 class="blog-date"><span>16 </span>Oct 2020 </h6>
			  </div>
	  
          
          
		
			
<p>I&#8217;ve been meaning to go &#8220;camping&#8221; in Shanghai for a while, knowing that whatever activity I engaged in would probably be pretty different from what I know as &#8220;camping&#8221; in the USA. Well, on the October holiday, I finally did it&#8230; my first <em>glamping</em> experience. (And yes, they even call it &#8220;glamping&#8221; here in Shanghai, too&#8230; <span class="info" title="jīngzhì lùyíng">精致露营</span> in Chinese.)</p>



<figure class="wp-block-image"><a href="https://www.flickr.com/photos/jpasden/50493140952/in/dateposted/"><img src="https://live.staticflickr.com/65535/50493140952_c8964b022c_b.jpg" alt="Shanghai Morning Glamping" data-lazy-src="https://live.staticflickr.com/65535/50493140952_c8964b022c_b.jpg?is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" class=" jetpack-lazy-image"><noscript><img src="https://live.staticflickr.com/65535/50493140952_c8964b022c_b.jpg" alt="Shanghai Morning Glamping"/></noscript></a></figure>



<p>The campgrounds are located within a large park on Changxing Island <span class="info" title="Chángxīng Dǎo">长兴岛</span> (near Chongming Island <span class="info" title="Chóngmíng Dǎo">崇明岛</span>) called <span class="info" title="Chángxīng Dǎo Jiāoyě Gōngyuán">长兴岛郊野公园</span> (<em>Changxing Dao Jiaye Gongyuan</em>). You pay for a park ticket (and dogs can get in too, if you buy their tickets), and then you can pay additional fees to rent out a tent for a night (complete with air mattresses), or for a space to pitch your own tent. (Guess which option most people choose?)</p>



<figure class="wp-block-image"><a href="https://www.flickr.com/photos/jpasden/50492991901/in/dateposted/"><img src="https://live.staticflickr.com/65535/50492991901_2510b7f33d_b.jpg" alt="Shanghai Morning Glamping" data-lazy-src="https://live.staticflickr.com/65535/50492991901_2510b7f33d_b.jpg?is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" class=" jetpack-lazy-image"><noscript><img src="https://live.staticflickr.com/65535/50492991901_2510b7f33d_b.jpg" alt="Shanghai Morning Glamping"/></noscript></a></figure>



<figure class="wp-block-image"><a href="https://www.flickr.com/photos/jpasden/50492991486/in/dateposted/"><img src="https://live.staticflickr.com/65535/50492991486_ecd77e949c_b.jpg" alt="Shanghai Morning Glamping" data-lazy-src="https://live.staticflickr.com/65535/50492991486_ecd77e949c_b.jpg?is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" class=" jetpack-lazy-image"><noscript><img src="https://live.staticflickr.com/65535/50492991486_ecd77e949c_b.jpg" alt="Shanghai Morning Glamping"/></noscript></a></figure>



<figure class="wp-block-image"><a href="https://www.flickr.com/photos/jpasden/50492994336/in/dateposted/"><img src="https://live.staticflickr.com/65535/50492994336_800a9f39b9_b.jpg" alt="Shanghai Morning Glamping" data-lazy-src="https://live.staticflickr.com/65535/50492994336_800a9f39b9_b.jpg?is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" class=" jetpack-lazy-image"><noscript><img src="https://live.staticflickr.com/65535/50492994336_800a9f39b9_b.jpg" alt="Shanghai Morning Glamping"/></noscript></a></figure>



<p>You can basically rent or buy anything camping related you might want: pre-lit hibachis to do your cooking, kebabs of food ready to grill, a cookout set that you set up yourself, picnic tables and chairs, etc.</p>



<figure class="wp-block-image"><a href="https://www.flickr.com/photos/jpasden/50492280813/in/dateposted/"><img src="https://live.staticflickr.com/65535/50492280813_13eb0bd4ed_b.jpg" alt="Shanghai Morning Glamping" data-lazy-src="https://live.staticflickr.com/65535/50492280813_13eb0bd4ed_b.jpg?is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" class=" jetpack-lazy-image"><noscript><img src="https://live.staticflickr.com/65535/50492280813_13eb0bd4ed_b.jpg" alt="Shanghai Morning Glamping"/></noscript></a></figure>



<p>I&#8217;m pretty sure no open fires were allowed, but there was a public bonfire lit by the park employees at night.</p>



<figure class="wp-block-image"><a href="https://www.flickr.com/photos/jpasden/50492992871/in/dateposted/"><img src="https://live.staticflickr.com/65535/50492992871_9af4c3737c_b.jpg" alt="Shanghai Morning Glamping" data-lazy-src="https://live.staticflickr.com/65535/50492992871_9af4c3737c_b.jpg?is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" class=" jetpack-lazy-image"><noscript><img src="https://live.staticflickr.com/65535/50492992871_9af4c3737c_b.jpg" alt="Shanghai Morning Glamping"/></noscript></a><figcaption>Bonfire, not yet lit</figcaption></figure>



<p>As expected, there weren&#8217;t many &#8220;experienced campers&#8221; there. I overheard one lady who was shocked to discover that there were no showers at the park.</p>



<p>During the day, you see a lot of tents in non-camping areas of the park. In China tents are often used as shelter from the sun during a relaxing day in a park, rather than shelter from the elements for sleeping in at night.</p>



<figure class="wp-block-image"><a href="https://www.flickr.com/photos/jpasden/50492996491/in/dateposted/"><img src="https://live.staticflickr.com/65535/50492996491_be63f7f33c_h.jpg" alt="Shanghai Morning Glamping" data-lazy-src="https://live.staticflickr.com/65535/50492996491_be63f7f33c_h.jpg?is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" class=" jetpack-lazy-image"><noscript><img src="https://live.staticflickr.com/65535/50492996491_be63f7f33c_h.jpg" alt="Shanghai Morning Glamping"/></noscript></a></figure>



<p>All in all, it was enjoyable. It just wasn&#8217;t the &#8220;camping&#8221; that I know.</p>



<figure class="wp-block-image"><a href="https://www.flickr.com/photos/jpasden/50492989656/in/dateposted/"><img src="https://live.staticflickr.com/65535/50492989656_6fca0b963a_b.jpg" alt="Shanghai Morning Glamping" data-lazy-src="https://live.staticflickr.com/65535/50492989656_6fca0b963a_b.jpg?is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" class=" jetpack-lazy-image"><noscript><img src="https://live.staticflickr.com/65535/50492989656_6fca0b963a_b.jpg" alt="Shanghai Morning Glamping"/></noscript></a></figure>
<div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon-text sd-sharing"><h3 class="sd-title">Share this:</h3><div class="sd-content"><ul><li class="share-facebook"><a rel="nofollow noopener noreferrer" data-shared="sharing-facebook-9307" class="share-facebook sd-button share-icon" href="https://www.sinosplice.com/life/archives/2020/10/16/glamping-in-shanghai?share=facebook" target="_blank" title="Click to share on Facebook"><span>Facebook</span></a></li><li class="share-twitter"><a rel="nofollow noopener noreferrer" data-shared="sharing-twitter-9307" class="share-twitter sd-button share-icon" href="https://www.sinosplice.com/life/archives/2020/10/16/glamping-in-shanghai?share=twitter" target="_blank" title="Click to share on Twitter"><span>Twitter</span></a></li><li class="share-email"><a rel="nofollow noopener noreferrer" data-shared="" class="share-email sd-button share-icon" href="https://www.sinosplice.com/life/archives/2020/10/16/glamping-in-shanghai?share=email" target="_blank" title="Click to email this to a friend"><span>Email</span></a></li><li class="share-end"></li></ul></div></div></div>					
			
		<div class="post-sharing">
		<div class="blog-social"><span>Share</span> 
			<a class="facebook" href="http://www.facebook.com/sharer.php?u=https://www.sinosplice.com/life/archives/2020/10/16/glamping-in-shanghai&amp;t=Glamping in Shanghai" target="blank"><i class="fa-facebook"></i></a>
			<a class="google" href="https://plusone.google.com/_/+1/confirm?hl=en-US&amp;url=https://www.sinosplice.com/life/archives/2020/10/16/glamping-in-shanghai" target="_blank"><i class="fa-google"></i></a>
			<a class="twitter" href="https://twitter.com/intent/tweet?original_referer=https://www.sinosplice.com/life/archives/2020/10/16/glamping-in-shanghai&amp;text=Glamping in Shanghai&amp;tw_p=tweetbutton&amp;url=https://www.sinosplice.com/life/archives/2020/10/16/glamping-in-shanghai" target="_blank"><i class="fa-twitter"></i></a>
			<a class="linkedin" href="http://www.linkedin.com/shareArticle?mini=true&amp;url=https://www.sinosplice.com/life/archives/2020/10/16/glamping-in-shanghai&amp;title=Glamping in Shanghai&amp;source=Sinosplice"><i class="fa-linkedin"></i></a>
			<a class="email" href="mailto:?subject=Glamping in Shanghai&amp;body=https://www.sinosplice.com/life/archives/2020/10/16/glamping-in-shanghai"><i class="fa-envelope"></i></a>
		</div></div>
				 
          <br class="clear">
		  
			  <div class="post-tags"><i class="fa-tags"></i><a href="https://www.sinosplice.com/life/archives/tag/camping" rel="tag">camping</a><a href="https://www.sinosplice.com/life/archives/tag/entertainment" rel="tag">entertainment</a><a href="https://www.sinosplice.com/life/archives/tag/observations" rel="tag">observations</a><a href="https://www.sinosplice.com/life/archives/tag/shanghai" rel="tag">Shanghai</a></div><!-- End Tags -->
			 
			 <div class="next-prev-posts">
			 			  
			 </div><!-- End next-prev post -->

		
                  <div class="about-author-sec">		  
	
		  <img alt src="https://secure.gravatar.com/avatar/d859fc578d38acbdd93fcd1dfaef358a?s=90&#038;d=mm&#038;r=pg" class="avatar avatar-90 photo jetpack-lazy-image" height="90" width="90" loading="lazy" data-lazy-srcset="https://secure.gravatar.com/avatar/d859fc578d38acbdd93fcd1dfaef358a?s=180&#038;d=mm&#038;r=pg 2x" data-lazy-src="https://secure.gravatar.com/avatar/d859fc578d38acbdd93fcd1dfaef358a?s=90&amp;is-pending-load=1#038;d=mm&#038;r=pg" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img alt='' src='https://secure.gravatar.com/avatar/d859fc578d38acbdd93fcd1dfaef358a?s=90&#038;d=mm&#038;r=pg' srcset='https://secure.gravatar.com/avatar/d859fc578d38acbdd93fcd1dfaef358a?s=180&#038;d=mm&#038;r=pg 2x' class='avatar avatar-90 photo' height='90' width='90' loading='lazy'/></noscript>		  <h5>John Pasden</h5>
		   <p>John is a Shanghai-based linguist and entrepreneur, founder of <a href="https://www.allsetlearning.com/">AllSet Learning</a>.</p>
		  

		  
		  </div>
		          </div>
				
      </article>
      <div class="comments-wrap">
<div class="commentbox">

         <div class="post-bottom-section">
<div class="right">
			
			</div>
		</div>
		
			

		<div id="respond" class="comment-respond">
							<h3 id="reply-title" class="comment-reply-title">Leave a Reply					<small><a rel="nofollow" id="cancel-comment-reply-link" href="/life/archives/2020/10/16/glamping-in-shanghai#respond" style="display:none;">Cancel reply</a></small>
				</h3>
						<form id="commentform" class="comment-form">
				<iframe title="Comment Form" src="https://jetpack.wordpress.com/jetpack-comment/?blogid=144154873&#038;postid=9307&#038;comment_registration=0&#038;require_name_email=1&#038;stc_enabled=1&#038;stb_enabled=1&#038;show_avatars=1&#038;avatar_default=mystery&#038;greeting=Leave+a+Reply&#038;greeting_reply=Leave+a+Reply+to+%25s&#038;color_scheme=light&#038;lang=en_US&#038;jetpack_version=9.0.2&#038;show_cookie_consent=10&#038;has_cookie_consent=0&#038;token_key=%3Bnormal%3B&#038;sig=7cfe714e564be798bcf5dae4df35ca3de1be6af2#parent=https%3A%2F%2Fwww.sinosplice.com%2Flife%2Farchives%2F2020%2F10%2F16%2Fglamping-in-shanghai" style="width:100%; height: 430px; border:0;" name="jetpack_remote_comment" class="jetpack_remote_comment" id="jetpack_remote_comment" sandbox="allow-same-origin allow-top-navigation allow-scripts allow-forms allow-popups"></iframe>
									<!--[if !IE]><!-->
					<script>
						document.addEventListener('DOMContentLoaded', function () {
							var commentForms = document.getElementsByClassName('jetpack_remote_comment');
							for (var i = 0; i < commentForms.length; i++) {
								commentForms[i].allowTransparency = false;
								commentForms[i].scrolling = 'no';
							}
						});
					</script>
					<!--<![endif]-->
							</form>
		</div>

		
		<input type="hidden" name="comment_parent" id="comment_parent" value="" />

		</div>
</div>    </section>
    <!-- end-main-conten -->
        <aside class="col-md-3 sidebar">
    <div class="widget"><h4 class="subtitle">John&#8217;s Products</h4>			<div class="execphpwidget"><p style="padding:0.6em">Sign up for the AllSet Learning Product Newsletter and find out what new Chinese learning projects John is working on. (No spam!)</p>

<!-- Begin Mailchimp Signup Form -->
<link href="//cdn-images.mailchimp.com/embedcode/slim-10_7.css" rel="stylesheet" type="text/css">
<style type="text/css">
	#mc_embed_signup{background:#fff; clear:left; font:14px Helvetica,Arial,sans-serif; }
	/* Add your own Mailchimp form style overrides in your site stylesheet or in this style block.
	   We recommend moving this block and the preceding CSS link to the HEAD of your HTML file. */
</style>
<div id="mc_embed_signup">
<form action="https://allsetlearning.us6.list-manage.com/subscribe/post?u=0cbb698d60507decec2f3a0bd&amp;id=b3c0cba5c4" method="post" id="mc-embedded-subscribe-form" name="mc-embedded-subscribe-form" class="validate" target="_blank" novalidate>
    <div id="mc_embed_signup_scroll">
	<label for="mce-EMAIL">Subscribe to our mailing list</label>
	<input type="email" value="" name="EMAIL" class="email" id="mce-EMAIL" placeholder="email address" required>
    <!-- real people should not fill this in and expect good things - do not remove this or risk form bot signups-->
    <div style="position: absolute; left: -5000px;" aria-hidden="true"><input type="text" name="b_0cbb698d60507decec2f3a0bd_b3c0cba5c4" tabindex="-1" value=""></div>
    <div class="clear"><input type="submit" value="Subscribe" name="subscribe" id="mc-embedded-subscribe" class="button"></div>
    </div>
</form>
</div>

<!--End mc_embed_signup--></div>
		</div><div class="widget"><h4 class="subtitle">Subscribe to Blog via Email</h4>
            <form action="#" method="post" accept-charset="utf-8" id="subscribe-blog-blog_subscription-2">
				                    <div id="subscribe-text"><p>Enter your email address to subscribe to this blog and receive notifications of new posts by email.</p>
</div>                    <p id="subscribe-email">
                        <label id="jetpack-subscribe-label"
                               class="screen-reader-text"
                               for="subscribe-field-blog_subscription-2">
							Email Address                        </label>
                        <input type="email" name="email" required="required"
                        			                                                value=""
                            id="subscribe-field-blog_subscription-2"
                            placeholder="Email Address"
                        />
                    </p>

                    <p id="subscribe-submit">
                        <input type="hidden" name="action" value="subscribe"/>
                        <input type="hidden" name="source" value="https://www.sinosplice.com/life/archives/2020/10/16/glamping-in-shanghai"/>
                        <input type="hidden" name="sub-type" value="widget"/>
                        <input type="hidden" name="redirect_fragment" value="blog_subscription-2"/>
						                        <button type="submit"
	                        		                    	                        name="jetpack_subscriptions_widget"
	                    >
	                        Subscribe                        </button>
                    </p>
				            </form>
		
</div>     </aside>
    <!-- end-sidebar-->    <!-- end-sidebar-->
    <div class="white-space"></div>
  </section>
  
	<footer id="footer" class="litex">
	<section class="container footer-in">
	  <div class="col-md-6">
<div class="widget"><h5 class="subtitle">Featured Product:</h5>			<div class="textwidget"><a href="http://www.amazon.com/dp/B01CHNZ75A"><img src="/wp-content/uploads/2016/05/CGW-ebook-600_01.png" alt="Chinese Grammar Wiki ebook" data-lazy-src="/wp-content/uploads/2016/05/CGW-ebook-600_01.png?is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" class=" jetpack-lazy-image"><noscript><img src="/wp-content/uploads/2016/05/CGW-ebook-600_01.png" alt="Chinese Grammar Wiki ebook" /></noscript></a></div>
		</div></div>
<div class="col-md-3">
<div class="widget"><h5 class="subtitle">AllSet Learning Family</h5>
	<ul class='xoxo blogroll'>
<li><a href="http://www.allsetlearning.com" title="John Pasden&#8217;s Shanghai-based consultancy, focused on personalized learning">AllSet Learning</a></li>
<li><a href="https://resources.allsetlearning.com/chinese/grammar/" title="The only resource you need for Chinese grammar, free, comprehensive, and interconnected">Chinese Grammar Wiki</a></li>
<li><a href="https://resources.allsetlearning.com/chinese/pronunciation/" title="All the sounds of the Chinese language explained, with diagrams and a free online pinyin chart">Chinese Pronunciation Wiki</a></li>
<li><a href="http://www.mandarincompanion.com" title="A new generation of Chinese graded readers for a new generation of learners">Mandarin Companion</a></li>

	</ul>
</div>
</div>
<div class="col-md-3">

		<div class="widget">
		<h5 class="subtitle">Recent Articles</h5>
		<ul>
											<li>
					<a href="https://www.sinosplice.com/life/archives/2020/10/16/glamping-in-shanghai" aria-current="page">Glamping in Shanghai</a>
									</li>
											<li>
					<a href="https://www.sinosplice.com/life/archives/2020/10/13/known-rivers-by-aaliyah-bilal">Known Rivers by Aaliyah Bilal</a>
									</li>
											<li>
					<a href="https://www.sinosplice.com/life/archives/2020/10/09/goodbye-wilson">Goodbye, Wilson</a>
									</li>
											<li>
					<a href="https://www.sinosplice.com/life/archives/2020/09/29/how-not-to-learn-vocabulary">How NOT to Learn Vocabulary</a>
									</li>
											<li>
					<a href="https://www.sinosplice.com/life/archives/2020/09/23/cucumber-snakes-and-tofu-boxes">Cucumber Snakes and Tofu Boxes</a>
									</li>
					</ul>

		</div></div>
	  </section>
	<!-- end-footer-in -->
	<section class="footbot"><div class="container">
<div class="col-md-6">
<!-- footer-navigation left -->
<div class="footer-navi">All content © John Pasden, 2002-2019. All rights reserved.</div></div>
<div class="col-md-6">
<!-- footer-navigation right -->
	<img src="https://www.sinosplice.com/wp-content/uploads/2016/04/sinosplice-logo_480x176-300x110.png" width="65" alt=""> 
	</div>
</div></section>	<!-- end-footbot -->
	</footer>
	<!-- end-footer -->


<span id="scroll-top"><a class="scrollup"><i class="fa-chevron-up"></i></a></span></div>
<!-- end-wrap -->
<!-- End Document
================================================== -->

		<script type="text/javascript">
			jQuery(document).ready(function(){ 
				jQuery(function() {
				    var header = jQuery("#header.horizontal-w");
				    var navHomeY = header.offset().top;
				    var isFixed = false;
				    var $w = jQuery(window);
				    $w.scroll(function(e) {
				        var scrollTop = $w.scrollTop();
				        var shouldBeFixed = scrollTop > 200;
				        if (shouldBeFixed && !isFixed) {
				            header.addClass("sticky");
				            isFixed = true;
				        }
				        else if (!shouldBeFixed && isFixed) {
				            header.removeClass("sticky");
				            isFixed = false;
				        }
				        e.preventDefault();
				    });
				});
			});
		</script>
			<div style="display:none">
	<div class="grofile-hash-map-d859fc578d38acbdd93fcd1dfaef358a">
	</div>
	</div>

	<script type="text/javascript">
		window.WPCOM_sharing_counts = {"https:\/\/www.sinosplice.com\/life\/archives\/2020\/10\/16\/glamping-in-shanghai":9307};
	</script>
					<div id="sharing_email" style="display: none;">
		<form action="/life/archives/2020/10/16/glamping-in-shanghai" method="post">
			<label for="target_email">Send to Email Address</label>
			<input type="email" name="target_email" id="target_email" value="" />

			
				<label for="source_name">Your Name</label>
				<input type="text" name="source_name" id="source_name" value="" />

				<label for="source_email">Your Email Address</label>
				<input type="email" name="source_email" id="source_email" value="" />

						<input type="text" id="jetpack-source_f_name" name="source_f_name" class="input" value="" size="25" autocomplete="off" title="This field is for validation and should not be changed" />
			
			<img style="float: right; display: none" class="loading" src="https://www.sinosplice.com/wp-content/plugins/jetpack/modules/sharedaddy/images/loading.gif" alt="loading" width="16" height="16" />
			<input type="submit" value="Send Email" class="sharing_send" />
			<a rel="nofollow" href="#cancel" class="sharing_cancel" role="button">Cancel</a>

			<div class="errors errors-1" style="display: none;">
				Post was not sent - check your email addresses!			</div>

			<div class="errors errors-2" style="display: none;">
				Email check failed, please try again			</div>

			<div class="errors errors-3" style="display: none;">
				Sorry, your blog cannot share posts by email.			</div>
		</form>
	</div>
<script type='text/javascript' src='https://secure.gravatar.com/js/gprofiles.js?ver=202042' id='grofiles-cards-js'></script>
<script type='text/javascript' id='wpgroho-js-extra'>
/* <![CDATA[ */
var WPGroHo = {"my_hash":""};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.sinosplice.com/wp-content/plugins/jetpack/modules/wpgroho.js?ver=9.0.2' id='wpgroho-js'></script>
<script type='text/javascript' src='https://www.sinosplice.com/wp-content/themes/florida-wp/js/jquery.plugins.js' id='doubletab-js'></script>
<script type='text/javascript' src='https://www.sinosplice.com/wp-content/themes/florida-wp/js/florida-custom.js' id='custom_script-js'></script>
<script type='text/javascript' src='https://www.sinosplice.com/wp-content/plugins/jetpack/vendor/automattic/jetpack-lazy-images/src/js/lazy-images.min.js?ver=1.0.0' id='jetpack-lazy-images-js'></script>
<script type='text/javascript' src='https://www.sinosplice.com/wp-includes/js/wp-embed.min.js?ver=7f2676ed5edc5ccbeabab231e04548d1' id='wp-embed-js'></script>
<script async="async" type='text/javascript' src='https://www.sinosplice.com/wp-content/plugins/akismet/_inc/form.js?ver=4.1.6' id='akismet-form-js'></script>
<script type='text/javascript' id='sharing-js-js-extra'>
/* <![CDATA[ */
var sharing_js_options = {"lang":"en","counts":"1","is_stats_active":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.sinosplice.com/wp-content/plugins/jetpack/_inc/build/sharedaddy/sharing.min.js?ver=9.0.2' id='sharing-js-js'></script>
<script type='text/javascript' id='sharing-js-js-after'>
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-facebook', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomfacebook', 'menubar=1,resizable=1,width=600,height=400' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-twitter', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomtwitter', 'menubar=1,resizable=1,width=600,height=350' );
				return false;
			});
</script>

	<!-- start miniAudioPlayer initializer -->
	<script type="text/javascript">

	let isGutenberg = true;
	let miniAudioPlayer_replaceDefault = 1;
	let miniAudioPlayer_excluded = "map_excluded";
	let miniAudioPlayer_replaceDefault_show_title = 1;

	let miniAudioPlayer_defaults = {
				inLine:true,
                width:"85%",
				skin:"gray",
				animate:true,
				volume:.2,
				autoplay:false,
				showVolumeLevel:true,
				allowMute: true,
				showTime:true,
				id3:false,
				showRew:true,
				addShadow: false,
				downloadable:true,
				downloadPage: null,
				swfPath:"https://www.sinosplice.com/wp-content/plugins/wp-miniaudioplayer/js/",
				onReady: function(player, $controlsBox){
				   if(player.opt.downloadable && player.opt.downloadablesecurity && !false){
				        jQuery(".map_download", $controlsBox).remove();
				   }
				}
		};

    function initializeMiniAudioPlayer(){
         jQuery(".mejs-container a").addClass(miniAudioPlayer_excluded);
         jQuery("a[href*='.mp3'] ,a[href*='.m4a']").not(".map_excluded").not(".wp-playlist-caption").mb_miniPlayer(miniAudioPlayer_defaults);
    }

    //if(1)
        jQuery("body").addClass("map_replaceDefault");

	jQuery(function(){
     // if(1)
         setTimeout(function(){replaceDefault();},10);
      
      initializeMiniAudioPlayer();
      jQuery(document).ajaxSuccess(function(event, xhr, settings) {
        initializeMiniAudioPlayer();
      });
	});
	</script>
	<!-- end miniAudioPlayer initializer -->

	
		<!--[if IE]>
		<script type="text/javascript">
			if ( 0 === window.location.hash.indexOf( '#comment-' ) ) {
				// window.location.reload() doesn't respect the Hash in IE
				window.location.hash = window.location.hash;
			}
		</script>
		<![endif]-->
		<script type="text/javascript">
			(function () {
				var comm_par_el = document.getElementById( 'comment_parent' ),
					comm_par = ( comm_par_el && comm_par_el.value ) ? comm_par_el.value : '',
					frame = document.getElementById( 'jetpack_remote_comment' ),
					tellFrameNewParent;

				tellFrameNewParent = function () {
					if ( comm_par ) {
						frame.src = "https://jetpack.wordpress.com/jetpack-comment/?blogid=144154873&postid=9307&comment_registration=0&require_name_email=1&stc_enabled=1&stb_enabled=1&show_avatars=1&avatar_default=mystery&greeting=Leave+a+Reply&greeting_reply=Leave+a+Reply+to+%25s&color_scheme=light&lang=en_US&jetpack_version=9.0.2&show_cookie_consent=10&has_cookie_consent=0&token_key=%3Bnormal%3B&sig=7cfe714e564be798bcf5dae4df35ca3de1be6af2#parent=https%3A%2F%2Fwww.sinosplice.com%2Flife%2Farchives%2F2020%2F10%2F16%2Fglamping-in-shanghai" + '&replytocom=' + parseInt( comm_par, 10 ).toString();
					} else {
						frame.src = "https://jetpack.wordpress.com/jetpack-comment/?blogid=144154873&postid=9307&comment_registration=0&require_name_email=1&stc_enabled=1&stb_enabled=1&show_avatars=1&avatar_default=mystery&greeting=Leave+a+Reply&greeting_reply=Leave+a+Reply+to+%25s&color_scheme=light&lang=en_US&jetpack_version=9.0.2&show_cookie_consent=10&has_cookie_consent=0&token_key=%3Bnormal%3B&sig=7cfe714e564be798bcf5dae4df35ca3de1be6af2#parent=https%3A%2F%2Fwww.sinosplice.com%2Flife%2Farchives%2F2020%2F10%2F16%2Fglamping-in-shanghai";
					}
				};

				
				if ( 'undefined' !== typeof addComment ) {
					addComment._Jetpack_moveForm = addComment.moveForm;

					addComment.moveForm = function ( commId, parentId, respondId, postId ) {
						var returnValue = addComment._Jetpack_moveForm( commId, parentId, respondId, postId ),
							cancelClick, cancel;

						if ( false === returnValue ) {
							cancel = document.getElementById( 'cancel-comment-reply-link' );
							cancelClick = cancel.onclick;
							cancel.onclick = function () {
								var cancelReturn = cancelClick.call( this );
								if ( false !== cancelReturn ) {
									return cancelReturn;
								}

								if ( ! comm_par ) {
									return cancelReturn;
								}

								comm_par = 0;

								tellFrameNewParent();

								return cancelReturn;
							};
						}

						if ( comm_par == parentId ) {
							return returnValue;
						}

						comm_par = parentId;

						tellFrameNewParent();

						return returnValue;
					};
				}

				
				// Do the post message bit after the dom has loaded.
				document.addEventListener( 'DOMContentLoaded', function () {
					var iframe_url = "https:\/\/jetpack.wordpress.com";
					if ( window.postMessage ) {
						if ( document.addEventListener ) {
							window.addEventListener( 'message', function ( event ) {
								var origin = event.origin.replace( /^http:\/\//i, 'https://' );
								if ( iframe_url.replace( /^http:\/\//i, 'https://' ) !== origin ) {
									return;
								}
								jQuery( frame ).height( event.data );
							});
						} else if ( document.attachEvent ) {
							window.attachEvent( 'message', function ( event ) {
								var origin = event.origin.replace( /^http:\/\//i, 'https://' );
								if ( iframe_url.replace( /^http:\/\//i, 'https://' ) !== origin ) {
									return;
								}
								jQuery( frame ).height( event.data );
							});
						}
					}
				})

			})();
		</script>

		<script type='text/javascript' src='https://stats.wp.com/e-202042.js' async='async' defer='defer'></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:9.0.2',blog:'144154873',post:'9307',tz:'8',srv:'www.sinosplice.com'} ]);
	_stq.push([ 'clickTrackerInit', '144154873', '9307' ]);
</script>
</body>
</html>
<!-- Dynamic page generated in 0.868 seconds. -->
<!-- Cached page generated by WP-Super-Cache on 2020-10-16 22:21:27 -->

<!-- super cache -->